Chinese Scooter Club Forum Index

Home | Forum | Arcade

Turn signals dont work-brand new to chinese scooters

 
Post new topic   Reply to topic    Chinese Scooter Club Forum Index -> Body and Electrical Workshop
View previous topic :: View next topic  
Author Message
gstraitman



Joined: 17 Apr 2008
Posts: 146
Karma: +1

Location: lone star state

PostPosted: Thu Apr 17, 2008 4:14 pm    Post subject: Turn signals dont work-brand new to chinese scooters Reply with quote

Got my new Chuanl LB150T-19A yesterday.
Turn signals worked a couple of times but I think I abused the switch by not pressing in to reset. Rather I switched left and right without pressing 'in' to release.
Now the turn signals do nothing when I use the switch. wondering several things
- if a bulb burns out do all turn signal lights not work
- turn switch itself seems ok unless its broken inside how to check operation
-could it be the turn signal relay. in the manual its called "light controled switch" presume that the relay.

Anyone know how trouble shoot the turn signals

Thanks
Ferd Laughing


Back to top
View user's profile Send private message
Fox



Joined: 05 Jan 2007
Posts: 7443
Karma: -301

Location: Los Angeles

PostPosted: Thu Apr 17, 2008 7:46 pm    Post subject: Reply with quote

Turn signals are over-rated!

Just kidding. I have done my switch from left to right without cancelling it in-between a lot and it's fine. I would check the bulbs first, then take apart the switch itself and see if it's faulty. They sell replacement switches and relays. Post back with what you discover and your location if you need parts.

Good luck mate!


Back to top
View user's profile Send private message
gstraitman



Joined: 17 Apr 2008
Posts: 146
Karma: +1

Location: lone star state

PostPosted: Fri Apr 18, 2008 12:53 pm    Post subject: Reply with quote

I took off hte fairing and low and behold, loose connection on the plug to the switch. Wow I finally get lucky. Thanks for your help.
Where is a good place to buy parts in the Dallas area?
FErd


Back to top
View user's profile Send private message
thegraves



Joined: 10 Apr 2008
Posts: 33
Karma: +1

Location: Houston tx

PostPosted: Wed Apr 23, 2008 9:51 pm    Post subject: Reply with quote

I just posted about this company on another thread, but http://www.globalmotorimports.com/ they are in Houston, and are very nice guys. I bought a part from www.partsforchinesescooters.com which is their parts website and just noticed it came from Houston. I've been by, they have a warehouse with MANY parts in stock. Both guys are nice to deal with.

Justin



_________________
2005 Wildfire WF150-S all stock.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
gstraitman



Joined: 17 Apr 2008
Posts: 146
Karma: +1

Location: lone star state

PostPosted: Fri Apr 25, 2008 9:23 pm    Post subject: Reply with quote

great, just what I was looking for a parts warehouse
Ferd :D


Back to top
View user's profile Send private message
clodius



Joined: 26 May 2008
Posts: 47
Karma: +1

Location: Bucharest, Romania

PostPosted: Tue Jun 03, 2008 8:57 pm    Post subject: Reply with quote

My turn signals work whenever they want, meaning when I accelerate or when I kick the scooter on the front left side right where the relay is.
I've checked the plugings of the relay and they're ok.
It works for a couple of days and after that... Icon_angry_3
Any ideas? If I change the relay will it solve the problem?



_________________
Peugeot V-Clic - QM50QT-6
Back to top
View user's profile Send private message
Yellow Scooter



Joined: 20 Mar 2007
Posts: 7113
Karma: +78

Location: North Carolina USA

PostPosted: Wed Jun 04, 2008 3:31 pm    Post subject: Reply with quote

That should take care of it if no bulbs are burnt out.
Mine was that way when I 1st brought it home. That should be a covered fix. Mine was inside of the handlebar-dash. I took off the front panel (standing in front of the bike, facing the nose) and it was smack in front row-center. Hope yours is just as easy to get to... Wink



_________________
29997, 98, 99, 30,000 30,002!!
I told ya she'd do it!!

2006 QingQi QM150T-10V
25-Jan, 2007 to 13-Nov, 2011
Rest in peace!
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
clodius



Joined: 26 May 2008
Posts: 47
Karma: +1

Location: Bucharest, Romania

PostPosted: Wed Jun 04, 2008 3:48 pm    Post subject: Reply with quote

Thanks, I know how to remove the front cover, I've done it a couple of times.
The thing is that after I kick the relay it starts working. Maybe it's some broken wire, but certainly it's not from the bulbs. I don't know Sad



_________________
Peugeot V-Clic - QM50QT-6
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Chinese Scooter Club Forum Index -> Body and Electrical Workshop All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group
Theme created by Vjacheslav Trushkin
Effex-Media Web Resources

Scooters | Scooter Insurance | Moped Insurance | Direct Bikes | Direct Bikes Reviews


Free Forum Free Top Site List
Make this Forum Ad-Free




32049318